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Intermediate Excel
After you have created a worksheet, you can graphically represent the worksheet
data by creating a chart. Charts can make worksheet data clearer and easier to
understand. Excel enables you to create charts on a separate sheet or embedded on
the same sheet as the data.

Create A Chart Sheet
You can quickly create a chart by selecting the data to chart and pressing the [F11]
key. This automatically creates a column chart on a separate chart sheet.

Examine Chart Terminology
It is very important to know the different parts of a chart. When you click on a
chart object to modify it, the Current Selection group on the Format tab under
the Chart Tools ribbon will identify the part of the chart on which you are
modifying. Below are the different parts of a 2-D column chart.
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Chart Area

Grid Line
Plot Area

Legend

X Axis
Y Axis

Data Point

Data Series
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Chart Types
Excel provides many chart types to choose from when you are creating or
modifying charts. The type of chart that you use depends on the data that you
are charting. To change the chart type, click on the Change Chart Type icon
on the Chart ribbon. Each of the chart types is represented graphically on
the Chart Type palette. Below is a list of the chart types and a brief
description of their uses.
Chart

Use

Column

To display individual values for comparison. Categories are drawn
from the horizontal axis, and values are drawn from the vertical
axis.

Line

To show trends over time. Emphasizes time flow and rate of change,
rather than the amount of change.

Pie

To display one data series as a whole, with each of its parts
representing a percentage of that whole.

Bar

To display individual values for comparison. Categories are drawn
from the vertical axis, and values are drawn from the horizontal
axis.

Area

To display the importance of values over time. Emphasizes the
amount of change, rather than the time or rate of change.

XY (Scatter)

To plot coordinate values. Shows the relationship between numeric
values in several data series.

Stock

To illustrate the fluctuation of stock prices.

Surface

A three-dimensional surface that connects a set of data points. The
Surface chart is useful when you want to find optimum
combinations between two sets of data.

Doughnut

Similar to a pie chart, except that it can display more than one data
series.

Bubble

A variation of a scatter chart in which the data points are replaced
with bubbles, and an additional dimension of the data is represented
in the size of the bubbles.

Radar

To show changes or frequencies of data relative to a center point and
to each other.
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Change Chart Types
1. Click on the Change Chart Type icon on the ribbon. A dialog box will
display with all the chart types.

2. Click on the new chart type you want to select.
3. Click on the appropriate icon to the right of the chart type that you want to use.
4. Click OK.

Modify The Chart Sheet
Charts created by pressing the [F11] key do not always communicate the worksheet
data as clearly as you would like. You can add information to a chart to enhance its
readability. Anything on a chart that can be selected is considered an item, and can
be added to or deleted from the chart. The options to modify the chart on listed as
icons on the Chart Tools ribbon:
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There are two simple ways to access existing data/items in a chart:
 Click the Left mouse button on the item to select a series of values in the chart,
click on the Format menu under the Chart Tools ribbon, then click on the
Format Selection icon on the ribbon...


Click the Right Mouse Button on the data/item to display a shortcut menu, click
on Format Data Series, then change the appropriate options in the dialog box.

Add Chart Titles
1. Click on the Layout menu on the Chart Tools ribbon.
2. Click on Chart Titles icon.
3. Click on Above Chart.
4. Type the text in the Chart Title box at the top of the page.
5. Click on the Axis Titles icon
6. Click on the Primary Horizontal Axis Title and/or click on the primary
Vertical Axis Title.
7. Click on the appropriate option for the location of your axis title.
8. Type the text in the Axis Title box.
Change Data Series Colors
1. Click once on a column in the chart to select that series.
2. Click on the Format menu under the Chart Tools menu.
3. Click on the Shape Styles color that you want for the series.
4. Click on the Shape Fill icon to change the color of the series.
5. Click on the Shape Outline icon to change the color, weight and dash options
for the series.
6. Click on the Shape Effects icon to choose an effect for the series.
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Change Data Point Colors
1. Click the Left mouse button once on the first column in the chart. The entire
series will be selected.
2. Click the Left mouse button again on the first column in the chart. Only the
first column will now be selected.
3. Click on the Format menu on the Chart Tools ribbon.
4. Click on a new shape style, shape fill, and/or shape outline color
You can also click on the Picture, Gradient, and/or Texture options in the
Shape Fill icon’s drop-down list to add gradient fills, texture, patterns, or
pictures.

Add Data Labels
Data Labels are used to label individual data points. Data labels can be values or
labels. Unless a specific series is selected before you insert data labels, they are
automatically entered on the chart for all data series.
1. Click on the Layout menu on the Chart
Tools ribbon.
2. Click on the Data Labels icon.
3. Click on appropriate option for the location of
the data labels.
Change Data Label Alignment
1. Click on the first set of data labels to select
all the labels for that series.
2. Click on the Format Selection icon in the
Current Selection section of the Layout
menu on the Chart Tools ribbon. The
Format Data Labels dialog box will
display.
3. Click on the Alignment menu.
4. Change the Text Direction to Rotate all
text 270°.
5. Click on Close.
6. Repeat Steps 1-5 for each of the other sets of
data labels.
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Modify Chart Values
1. Click on the Sheet1 Tab at the bottom of the worksheet window to return to the
worksheet data.
2. Click in cell whose value will be changed.
3. Type in the new value and press [Enter].
4. Click on the Chart1 Tab at the bottom of the worksheet window to return to the
chart.
5. Notice that the value for that data point has changed.
Move The Legend
1. Click the Left mouse button on the Legend icon on the Layout menu on the
Chart Tools ribbon.
2. Click on the appropriate option that will place the legend in the desired location.
Format Values In The Y-Axis
1. Click the Left mouse button on any value on
the Y-Axis to select it.
2. Click on the Format menu on the Chart
Tools ribbon.
3. Click on the Format Selection icon.
4. Click on the Number menu on the left side of
the dialog box.
5. Click on the Number category.
6. Change the decimal places to zero (0).
7. Click on Close.
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Create A Pie Chart
Pie charts represent one set of data in the worksheet. For example, you may want
to compare total sales for all four quarters of one year, or you may want to see total
costs for one area in the country. Below are instructions for creating a pie chart:
1. Select the range of data in the worksheet that will describe
the numbers being charted.
2. Hold down the [Ctrl] key and select the range of data that
is to be charted.
3. Click on the Insert menu.
4. Click on the Pie icon on the ribbon.
5. Click on the Pie Chart type that you want to create.

Print A Chart Sheet
When sending a Chart Sheet to the printer, the entire page is filled with the chart.
If you are printing to a color printer, the chart will be in color. If you are printing to
a laser printer, the chart will print in black and white. The print Setup options are
available just as they are in a worksheet environment.
1. Click on the Print Preview icon on the Quick Access Toolbar.
2. Click on the Page Setup icon and view/change the options.
3. Click OK.
4. Click on the Print icon.
5. Click OK.

Create An Embedded Chart
When you use the chart icons found in the Insert menu, Excel draws the chart
according to the selections you make in the dialog box and embeds the chart as an
object on the worksheet. You format an embedded chart just as you would format a
chart sheet.
1. Click on the Sheet1 Tab at the bottom of the window.
2. Select the range to chart (The column headings and data.)
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3. Click on the Insert menu on the ribbon.
4. Click on the appropriate Chart Type.
5. Click on the appropriate Chart Sub-type.
6. Click on the appropriate Chart Layout.

Move The Embedded Chart
Because an embedded chart is an object on the worksheet, you can move it around
by dragging it. When you place the mouse pointer anywhere inside the chart, it
turns into a four-headed arrow for moving the object.
1. Click once on the chart to make it active (it will have handles around the outside
edge.)
2. Place the mouse pointer inside the chart area (it will turn into a four-headed
arrow.)
3. Hold down the Left mouse button and drag the chart to another location on the
worksheet.
4. Release the Left mouse button.

Size The Embedded Chart
You can size an embedded chart by using the selection handles that are displayed
around the chart. When you place the mouse pointer on one of the selection
handles, it changes into a two-headed arrow. Dragging the mouse in the direction
of the arrow will either enlarge or reduce the size of the chart.
1. Place the mouse pointer on any outside handle (it will turn into a two-headed
arrow.)
2. Hold down the Left mouse button and drag the mouse in the direction of the
arrow (up, down, left, or right.) The object will change sizes accordingly.
3. Release the Left mouse button.

Print An Embedded Chart
You can print an embedded chart as part of the worksheet or separately. When you
print an embedded chart as part of the worksheet, the size, proportions, and
position of the chart on the printout correspond to how the embedded chart is sized
on the worksheet.
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1. Click off of the chart onto the worksheet to de-activate the chart.
2. Press [Ctrl] + [Home] to return to the top of the worksheet.
3. Click on the Printer icon or click on the File, Print Menus to display the Print
dialog box.
To print an embedded chart on a page by itself, you must first activate the chart by
clicking on it.
1. Click on the chart to make it active.
2. Click on the Printer icon or click on the File, Print Menus to display the Print
dialog box.

Sorting Data
A list is an organized collection of related information. Lists are arranged in a
column and row format. A common example of a list is a telephone book. Lists can
be sorted in ascending and/or descending order. Lists can be sorted by one column
at a time, or by multiple columns. Sorting by one or more columns will sort the
entire list, not just the column(s) you sort. Clicking on the Undo icon will undo the
sort.

Perform A Quick, One-column Sort
To sort a list of information by one column, all you have to do is click in the
column by which to sort and click on the Ascending or Descending icon on
the Home ribbon.

Perform A Multi-column Sort
To sort by more than one column, you must click on the Data menu then
click on the Sort icon. The Sort dialog box will display on the screen
allowing you to add levels by which to sort.
1. Click anywhere inside the worksheet data.

Page 10

2. Click on the Data menu then click on the Sort icon.

3. Click on the down arrow to the right of the Sort by box and choose the column
by which to sort.
4. Click on the down arrow to the right of the Sort On box and choose the
appropriate option.
5. Click on the down arrow to the right of the Order box and choose the
appropriate order.
6. Click on the Add level button at the top of the dialog box to add additional
levels on which to sort the data.
7. Click OK when finished.

Create A Custom Sort List
There may be times when you have data in your list that will not sort correctly in
Ascending or Descending order. For example, if you had the months of the year
in a list and you wanted them sorted in the order that they are on the calendar,
clicking on the Ascending or Descending icons would not do it. Sorting the
months in Ascending order would result in April, August, December, February,
January, July, March, May, November, October, and September.
The only way to sort the months in the correct calendar order is to create a custom
sort option.
1. Click in the appropriate column in which you want to sort the data.
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2. Click on the Data menu then click on the Sort icon.
3. Click on the down arrow to the right of the Sort On box and choose the
appropriate option.
4. Click on the Down Arrow to the right of the Order option and click on the
Custom List option. The Custom Lists dialog box will display.

5. Click on the options in the Custom Lists section that matches the order in
which you need to sort.
6. Click OK.
7. Click OK.

Creating Sort Order Lists Not Found In Excel
There may be times that you will want to sort a list in a manner that is not found in
the Options button in the Sort dialog box. For example, if you have a list that is
High, Low, Medium, sorting it in Ascending or Descending order will never put it
in Low, Medium, High order. Excel allows you to create customized sort lists to
resolve this problem.
1. Click in the appropriate column in which you want to sort the data.
2. Click on the Data menu then click on the Sort icon.
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3. Click on the down arrow to the right of the Sort On box and choose the
appropriate option.
4. Click on the down arrow to the right of the Order box and choose the
appropriate order.
5. Click on the Down Arrow to the right of the Order option and click on the
Custom List option. The Custom Lists dialog box will display.

6. Click in the List Entries box and type your list. The entries must be separated
by a comma.
7. Click on Add.
8. Click OK.
9. Click OK.

Using Subtotals
Automatic subtotals are useful in summarizing the data contained in a list.
Subtotals are created by using Sum, Count, or Average functions. To use subtotals,
the data must be organized in a properly designed list.

Turn On Subtotals
1. Open Sort Data.xlsx.
2. Click on the Payroll worksheet tab.
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3. Click in the LOCATION column and click on the Sort Ascending icon on the
Standard Toolbar.
4. Click on the Data menu, then click on the Subtotals icon.
5. Click on the Down Arrow at the At Each
Change in field.
6. Click on LOCATION.
7. Click in the HOURLY RATE and GROSS PAY
boxes to add a checkmark.
8. Click OK. Notice that the list is subtotaled at the
end of each location.

Remove Subtotals
1. Click anywhere inside the list.
2. Click on the Data menu, then click on the
Subtotals icon.
3. Click on Remove All.

Filtering A List
Filtering a list only displays the sets of data that meet a certain set of search
conditions called criteria. There are two types of filters: AutoFilter and
Advanced Filter. The AutoFilter command displays drop-down list arrows next
to each column label in the list. When you click on the drop-down list arrow, a list
of all the unique entries for that column is displayed. The Advanced Filter is used
to filter complex criteria.

Turn On AutoFilter
1. Open Sort Data.xlsx.
2. Click on the Data menu then click on the Filter icon. Drop-down arrows will
display to the right of each column heading.
3. Click on the drop-down arrow for the appropriate field and click on the field by
which to filter the data.
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Perform Custom Filters
The Custom filter criterion allows you to filter a list to display sets of data that
contain either of two unique entries in one column. This creates an OR condition.
You can filter a list by selecting a criterion from multiple columns. This creates an
AND condition.
1. Click on the Drop-down arrow to the right of LOCATION.
2. Click on Text/Number Filters.
3. Click on Custom Filter.
The Custom AutoFilter dialog box will display on the window.

4. Ensure that the first box has equals in it.
5. Click on the down-arrow to the right of the blank box and click on Ashville.
6. Click on Or.
7. Ensure that the second box has equals in it.
8. Click on the down-arrow to the right of the second blank box and click on
Boone.
9. Click OK. The list will display only those two criteria.
10. Click on the down-arrow to the right of the LOCATION column.
11. Click on Clear filter from ‘LOCATION’ to display all the rows again.
12. Click on the Down-arrow to the right of LOCATION and click on the (Select
All) box to remove all the check marks from the list.
13. Click on Blue Ridge.
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14. Click OK.
15. Click on the down-arrow to the right of BEN and click on the (Select All) box to
remove all the check marks from the list.
16. Click on R to create an AND condition.
17. Click OK.
18. Click on the down-arrow to the right of the LOCATION column.
19. Click on Clear filter from ‘LOCATION’ to display all the rows again.
20. Click on the down-arrow to the right of the BEN column.
21. Click on Clear filter from ‘BEN’ to display all the rows again.

Turn Off AutoFilter
When you no longer need to filter a list, you can turn it off.
1. Click on the Data menu then click on the Filter icon.

Perform An Advanced Filter
Sometimes, the filter criteria that you specify with AutoFilter will not yield the
needed results. For example, you cannot use AutoFilter to filter a list to display
the more complex criteria of two separate And conditions combined with an Or
condition.
Advanced Filters require a list of information and a criteria range. The result can
be displayed in a separate section in the worksheet or it can hide all the rows in the
list that do not meet the specified criteria. The criteria range must contain column
headings exactly as they are entered in the original list. The easiest way to do this
is to copy the heading(s) from the list into the criteria range.
(Ensure that Sort Data.xlsx is open and that you are on the Payroll worksheet)
1. Select the LOCATION and ACTIVITY column headings.
2. Click on the Copy icon on the Home menu on the ribbon.
3. Click in Cell M1 and press [Enter]. To copy the column headings into Cells M1
and N1.
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4. Click in Cell M2 and type Boone.
5. Press [Tab], type Art Galleries and press [Enter].
6. In Cell M3, type Ashville.
7. Press [Tab], type Parkway Drive and press [Enter].
8. Click anywhere inside the list of information.
9. Click on the Data menu and click on the Advanced
button. The Advanced Filter dialog box will display
on the window.
10. Click on Copy to Another Location.
11. Click in the Criteria Range box and type M1:N3.
12. Click in the Copy to box and type M10.
13. Click OK to create the new Advanced Filter results.
14. Close the document without saving the changes.

Data Forms
A data form is a convenient way to enter or display one complete row of information,
or record, in a list at a time. Before you can use a data form to add a record to a new
list, the list must have labels at the top of each column in the list. Microsoft Excel
uses these labels to create fields on the form. Note: Data forms can display a
maximum of 32 fields at one time.
The following requirements must be met when creating a data form:



The field names must look different from the rest of the data. It can be bolded,
uppercase, italicized, etc.
There can be no space between the field names and the first line of data.

Create A Data Form
1. Create a new worksheet.
2. Type the appropriate column headings across Row 1 (i.e., First, Last, Address,
City, State, Zip).
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3. Select the column headings and apply a formatting option (i.e., bold, underline,
italicize).
4. Add the Form button to the Quick Access Toolbar, using the following
instructions:
a. Click the arrow next to the Quick Access Toolbar, and then click More
Commands.
b. In the Choose commands from box, click All Commands, and then select
the Form button in the list.
c. Click Add, and then click OK.
5. Click on one of the column headings and then click on the Form icon on
the Quick Access Toolbar. The Form dialog box will display.

Enter Data Into The Form


Type information into each field.



Press [Tab] to move between the fields.



Press [Enter] to create a new blank record.



Click on Close when finished.
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