2016 NC Baptist Secretaries Conference
Advanced Excel
Work With Multiple Worksheets
By default, a Microsoft Excel Workbook consists of 3 Worksheets. The maximum number of
worksheets in a workbook is 255. (Note: Worksheets can be named by double-clicking on the sheet
tab and typing in a name of up to 31 characters, including spaces.) If most of the information inside
multiple worksheets is the same, you can enter it simultaneously and then later complete the rest of the
data that is different.
You can work with multiple worksheets inside a workbook. These sheets can be adjacent or nonadjacent.
Select Multiple Adjacent Worksheets:
1. Click on the first sheet tab to select.
2. Hold down the [Shift] key and click on the last sheet tab to be selected. (For example: Click on
Sheet1, hold down the [Shift] key and click on Sheet3. Sheets 1 – 3 will be selected.)
Select Nonadjacent Worksheets:
1. Click on the first sheet tab to select (Sheet1).
2. Hold down the [Ctrl] key and click on Sheet 3. (Only sheets 1 and 3 will be selected.)
De-select Worksheet Tabs:
1. Click on any non-selected worksheet tab.
OR
Click the Right Mouse Button on any selected worksheet tab and click on Ungroup Sheets.

Create And Format Multiple Worksheets
If multiple worksheets inside the file are going to contain the same information and be formatted the
same, it will be quicker to select the worksheets and create them simultaneously. Type everything that is
the same and format it accordingly. Just do not enter the information that is different (yet.)
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Move Worksheets Within A Workbook
You can change the order of the worksheets within a workbook by dragging the sheet tab from one
location to another along the bottom of the screen. To move several sheets at once, select multiple sheets
and drag.
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Move Worksheets Between Workbooks
You can also move worksheets to a new blank document or to an existing workbook. The existing
workbook must be opened before you can move a worksheet into it. Click the Right Mouse Button on the
sheet tab and click on Move or Copy. Select the destination workbook and where in the workbook you
want the sheet to be placed. (Remember: you are moving this sheet out of this workbook into
another file.)
Copy Worksheets Within A Workbook
Instead of moving worksheets from one workbook to another, you can copy them. This leaves a copy of
the worksheet in the original file as well as one in another file. To copy a sheet to a new location in the
same workbook, select the sheet tab. Hold down the [Ctrl] key and drag the sheet tab to a new location.
To copy several sheets at once, select multiple sheets and drag.
Copy Worksheets Between Workbooks
You can also copy worksheets to another workbook. Click the Right Mouse Button on the sheet tab and
click on Move or Copy. Select the destination workbook and where in the workbook you want the sheet
to be placed. You must click on the Create A Copy option at the bottom of the Move or Copy Dialog
Box, or you will be moving the worksheet instead of copying it.
Insert A New Worksheet
You can insert a new worksheet at any time inside the workbook. You get 3 worksheets by default in a
new workbook, so if you insert a new one it will be named Sheet4.
1. Right-click on an existing worksheet tab
2. Click on Insert…
3. Click OK.
Delete A Worksheet
You can delete worksheets at any time as well. (Note: If you delete a worksheet, you cannot click on
Undo to get it back!)
1. Right-click on the worksheet tab to delete
2. Click on Delete
3. Click OK
Summarize Multiple Worksheets
You can summarize numbers in multiple worksheets into a Summary Sheet. This allows you to view the
total for all the sheets combined, or look at the totals for individual sheets. An example of how this
would be used is in an annual budget. You would have an individual sheet for Qtr 1, Qtr 2, Qtr 3, and Qtr
4. You would then have another sheet that would total the four quarters and be able to view the entire
year’s budget on one sheet.
1. Open Sales Workbook.xls.
2. Click in Cell C5.
3. Type =sum(
4. Click on the Jones tab and click in Cell C5.
5. Hold down the [Shift] key and click on the Andrews tab.
6. Press [Enter] to complete the formula.
7. Click in Cell D5.
8. Type =sum(
9. Click on the Jones tab and click in Cell D5.
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10. Hold down the [Shift] key and click on the Andrews tab.
11. Press [Enter] to complete the formula.
12. Click in Cell E5.
13. Type: =sum(
14. Click on the Jones tab and click in Cell E5.
15. Hold down the [Shift] key and click on the Andrews tab.
16. Press [Enter] to complete the formula.
17. Select Cells C5:E5.
18. Place the mouse pointer on the lower-right corner of the selected area.
19. Hold down the Left Mouse Button and drag down to Row 14.
20. Save and close the file.
Calculate Single Cells From Multiple Worksheets
You can also create formulas that will calculate values within multiple worksheets and/or files without
using the SUM function. In this case you would make sure that you have all of the files open that contain
the values to be calculated. You add the values to the formula by clicking on the appropriate worksheet
and cell.
1. Open Advanced Formulas.xlsx and Sales.xlsx files.
2. Click in Cell B1.
3. Type =
4. Click on Cell G14.
5. Press: +
6. Click on Cell G31.
7. Press: +
8. Click on the View tab
9. Click on the Switch Windows icon
10. Click on Advanced Formulas.xls to switch to that file.
11. Click on Cell F6.
12. Press: [Enter].
13. Press the [Up Arrow] key on the keyboard.
14. Look at the formula in the Formula Bar.
15. Close both files.

Freeze Panes
When a worksheet is too large to fit on the window, it can be helpful to use the Freeze Panes command
to “lock” certain rows or columns of information on the window while you scroll through the rest of the
worksheet.
If column and/or row headings disappear as you scroll through the worksheet, you need to Freeze Panes.
This assists you in knowing what data to enter into the spreadsheet and where to enter it.
Page 3

1. Open 5 Year Loan.xls.
2. Click on the Payments tab at the bottom of the window.
3. Click on the Down Arrow on the Vertical Scroll Bar. Notice that Rows 1 – 10 scroll out of site very
quickly.
4. Click in Cell A11.
5. Click on the View menu
6. Click on the Freeze Panes icon.
7. Click on Freeze Panes.
8. Click on the Down Arrow on the Vertical Scroll Bar. Notice that Rows 1 – 10 remain on the window
as you scroll.

Remove Freeze Panes
1. Click on the View menu
2. Click on the Freeze Panes icon.
3. Click on Unfreeze Panes.

Create Print Titles
The Print Titles option prints the same column and/or row headings at the top of every page. If the
printout contains multiple pages, you might want a title on top of each page, or in the first column of each
page. Print Titles will do this for you.
1. Open 5 Year Loan.xls.
2. Click on the Payments tab at the bottom of the window.
3. Click on the Page Layout tab.
4. Click on the Print Titles icon.
5. Click in the Rows to repeat at top: box.
6. Type a1:a4.
7. Click on the Print Preview button on the right side of the
Dialog Box.
8. Scroll through the preview pages and notice the row
headings print at the top of each page.
9. Click on Close.
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Concatenating data
Now let's look at the opposite situation. Suppose that you've already split data into two or more columns
and now you decide you want it combined. (That's what concatenate means -- to combine.)
Concatenating data temporarily
To merge data temporarily, create a new column, and in it, set up formulas that concatenate the values of
the individual cells.
Let's do this with the example file: sort data.xlsx
In cell M1, enter the formula =B5&" "&C5.
The & sign is the concatenation operator, so technically =A1&B1 would put the two values together.
However, there would be no space between them. That's why the " " exist. It's a space, nestled between
two quotation marks.
Note: You can also use the CONCATENATE function to do the same thing, like this:
=CONCATENATE(Al," ",B2)
Notice that with the function, you separate the pieces with commas rather than & signs because each
piece is a separate argument.

Pivot Tables
Pivot Tables are used in Excel to quickly summarize, organize, analyze, and/or compare large amounts of
data. The data used to create a Pivot Table is called the source data. Pivot Tables simplify the process
of summarizing data in the worksheet. Pivot Tables consist of row and column headings that can be
rotated to generate different configurations of the data. If the source data changes, you can update the
Pivot Table.

Create A Pivot Table Using the PivotTable Wizard
The PivotTable Wizard displays boxes that use data fields to create the Pivot Table.
1. Open Pivot Table.xlsx.
2. Click anywhere inside the list of data.
3. Click on the Insert menu.
4. Click on PivotTable icon.
5. Click on OK.
6. Drag the Year field to the Report Filter box.
7. Drag the Area field to Row Labels box.
8. Drag the Month field to Column Labels box.
9. Drag the Sales field to Values box.
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Change and Reorganize Data in a Pivot Table
To change the way data is displayed in the pivot table, click on the down arrow beside specific fields in
the spreadsheet and change options. (For example, instead of showing all the years, click on a specific
year.)

Refresh a Pivot Table
If the source data changes after you create a Pivot Table, you can update or refresh the table to reflect the
changes to the source data. The changes made when you refresh the Pivot Table include:


Data field changes made in the source data.



Deleted items or fields from the source data.



Existing row or field data that have been changed or added in the source data.

1. Click on the Options menu in the PivotTable Tools toolbar.
2. Click on the Refresh icon in the Data group on the ribbon.

Deleting A Field From A Pivot Table
You can easily change which portion of the source data appears in a pivot table by removing whole fields.
A pivot table must have a least one field; therefore, you cannot delete all of the fields.

Group Selected Items In A PivotTable
There may be times when you want to summarize data at a higher level than the source data allows. This
can be done by grouping items within PivotTable fields. For example, if you have three Engineering
departments (Chemical, Electrical, and Support), you can group them as Engineering so that their data are
summarized together. Excel will not automatically name the new group. You must select the default
group name (Group1, Group2, etc.) and type in the desired heading name.
Items can be grouped in one of three ways, depending on the item type:
 Grouping items by categories (as in Qtr1, Qtr2, etc.)


Grouping numeric items into ranges (grouping inventory numbers.)



Grouping dates and times into larger time units (grouping dates into months, quarters, or years.)

1. Select the items you want to combine.
2. Click the Right Mouse Button inside the selected area and click on Group. Microsoft Excel creates a
new item that combines the selected items and adds a group field to the PivotTable. Excel adds a
new row heading (Group1, Group2, etc.)
3. Click on the heading Group1 and type the new heading name (i.e., Qtr1).
4. Click on the new field button to select it and type a new name (i.e., Quarters).

Ungroup Items In A PivotTable
To return the items back to their original view, you must Ungroup them. You cannot ungroup a single
set of numbers, dates, or times that you've grouped at the same time; Microsoft Excel ungroups all sets.

Show Pages
The PivotTable will create a separate worksheet for each of the items in the Page field. For example, if
you have Area as the Page field, the Show Pages option will create a worksheet for each area. You can
also create individual pages by double-clicking on a cell that has a value in it.
1.
2.
3.
4.

Drag the appropriate button to the Page area of the PivotTable (Year, Area, etc.)
Click the Left Mouse Button anywhere inside the PivotTable.
Click on the down arrow to the right of the Options icon.
Click on Show Report Filter Pages. A new worksheet will be created for each item in that field.
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